wiki:KiCAD5SchematicTips

KiCAD 5 Schematic Tips

Up to KiCAD Notes

Table of Contents

Before starting schematic

  • Read this page completely
  • Find datasheets for all the parts you plan to use (Pro tip: put them in your repository in a "datasheets" folder)
  • Understand data fields required for the bill of materials bom-fields (and how to add them).
  • Organize your directories:
  $ mkdir my_project             # please use a meaningful name!
  $ mkdir my_project/lib         # schematic symbol ".lib" files go here
  $ mkdir my_project/mod         # PCB footprint files ".pretty" go here

Now, start KiCAD, select File->New->Project and navigate to the my_project directory. Create the design there, naming the board (I'll use board1 for example).

Your directory tree should look like this:

$ tree eric_kicad_example/
eric_kicad_example/
├── board1
│   ├── board1.kicad_pcb
│   ├── board1.pro
│   └── board1.sch
├── lib
└── mod

Symbols and Libraries

Now you can start on the schematic. You will find that you can use some schematic symbols from the library(s) supplied, and you may have to draw some of your own. Each symbol must live in a library (file with .lib type in the lib folder).

A library can contain multiple symbols. Here are some guidelines:

  • Integrated Circuits: use a separate library for each named after the part number, e.g. NE555.lib
  • Passives: this means Resistors, Capacitors and Inductors. Use one library called e.g. my_passives.lib
  • Connectors: Use one libary called e.g. my_connectors.lib

Create a Library

(if needed)

Open the symbol editor. menu: Tools->Edit Schematic Symbols in main KiCAD or Tools->Symbol Library Editor in the schematic.

Create a library: menu File->New Library

Navigate to the lib folder you created and enter the name, keeping the ".lib" so e.g. my_connectors.lib. You'll see a dialog Choose the Library Table, select Project. (this feature doesn't always work, so you may have to do it by hand, next step...).

Menu: Preferences->Manage Symbol Libraries. Select the tab Project Specific Libraries.

Click the folder icon "Add existing library to table" at the bottom. Navigate to find your new library (example: my_connectors.lib) and add it. Now you will see something like this:

https://ohm.bu.edu/~hazen/KiCAD/set-library-path.png

You have to edit it carefully to change the absolute path /home/hazen... to a relative one. Thus:

  change "/home/hazen/work/eric_kicad_example/lib/my_connectors.lib"
      to                      "${KIPRJMOD}/../lib/my_connectors.lib"

It should look like this:

https://ohm.bu.edu/~hazen/KiCAD/fix-library-path.png

Note: The reason to do this is so that when someone else grabs your design it doesn't look for the path /home/hazen/work... since this wouldn't be found on their computer.

Create a Symbol

Open the symbol editor. menu: Tools->Edit Schematic Symbols in main KiCAD or Tools->Symbol Library Editor in the schematic.

You will see a big list of libraries with a filter box at the top. Type the name of one of your libraries to find it. I like to name my libraries starting with a unique name like my_ to make this easier.

https://ohm.bu.edu/~hazen/KiCAD/my-libs.png

Right click on the library and menu New Symbol. Fill in the dialog box. Set the Symbol Name and the prefix (see https://en.wikipedia.org/wiki/Reference_designator for a lengthy explanation).

https://ohm.bu.edu/~hazen/KiCAD/create-new-symbol.png

Add pins and body to symbol per the KiCAD tutorial and documentation. Move the Value and Reference text to a reasonable place. Should look something like this. Menu File->Save.

https://ohm.bu.edu/~hazen/KiCAD/symbol-example.png

Now you can use your new symbol in your schematic. Note that multiple projects can reference the same libraries. You can do this by adding them one at a time or copying the file sym_lib_table from one project to another (assuming you set the relative paths correctly!).

Schematic Notes

A collection of random notes/pitfalls when using the schematic editor.

General Preferences

  • Run signals left-to-right from input to output if possible
  • Never make a connection at a signal crossing. Always offset.

https://ohm.bu.edu/~hazen/KiCAD/yes.png https://ohm.bu.edu/~hazen/KiCAD/no.png

Power, Ground, Passives

See example schematic below.

  • Use the power supply symbols, with voltage chosen (avoid VCC, VAA and things like that).
  • Always place at least one capacitor to GND on each power supply pin unless told otherwise
  • Always use the GND symbol for ground unless told otherwise
  • Place power and GND symbols where needed... don't connect power/gnd with long wires.
  • Use the "R_US" symbol for resistors (wiggly line, not box)
  • Move the text so it doesn't overlap graphics, looks neat and is easy to read. (if there isn't room, spread things out).
  • Flip symbols left-to-right and top-to-bottom to avoid wire crossings and enforce the left-to-right signal flow.

https://ohm.bu.edu/~hazen/KiCAD/schem1.png

Grid setting

This is a small point, but be certain your grid is set to 50 mils. Right-click in a blank part of the schematic, menu Grid->Grid: 50.00 mils. This should be the default, but if you find you can't connect wires to some pins this could be the cause.

Last modified 8 months ago Last modified on Feb 15, 2022, 3:38:24 PM